hi. Excuse me if this is the wrong space for this, but im having trouble with my mouse settings suddenly. Everything was fine and then at some point when I click the middle mouse button to try to scroll around it zooms way in sometimes inside or passed my object. And scrolling to zoom goes crazy fast and far. Like one middle mouse scroll notch will zoom inside my object.Β 
Anyone have a fix for this? It makes my scrolling basically unusable

Oh yea, I am on a MacΒ 
How are your navigation settings looking?
These are the standard ones:
Ahhh. I think the auto perspective may have been the problem. I had it on and orbit around object which ive found helpful. Thank you. I think that did it
Hit . (dot) and then it should bring the current object into view and zoom should be working fine again.
Usually it's a common camera issue (common for almost any 3D app).

To make it stop and get back to normal, just select any object from the outliner, then hit "." (dot/period) on the numeric pad (having the mouse over the 3D viewport).

That should do it.
What if I dont have a number pad?
Joe McGuinnessΒ 

Go to the preferences window (Edit --> Preferences), click on the Input (left column), and then select "Emulate Numpad".

This way you will be able to use the main numbers as if they were the numpad ones.
Mauro SannaΒ thats what I've been using, but there isn't a comma or dot on my number row on a mac...
Also have a look at your view clip planes, tell us what your settings look like (just hit "N" to make the side bar appear, and flick the "View" tab).

Log in to add a comment

Log in